Large image (100 MB) on IPFS not opening in browser

Hi all!

I have the following CID (pinned) for a large image: QmfP1NP4kCoeTHFGA1sykVGCUsHEMGCjWtK26nJ3yfi294

The good news is that I can download the file, put a “.jpg” extension on it and it will open as expected. The bad news is that I can’t open it in a browser on a public (or local) gateway, as after loading it for 10 secs, it just brings up a small white square (as if it errored out). I have tried all browsers except firefox.

Do you guys know if this is a problem/feature of the browser / file / IPFS? Let me know if you can perhaps open it in any other way.


That CID loads through my node’s gateway, but I can’t seem to get it from one of the public gateways.

This is likely an issue with the gateway both getting and sending the whole image within the expected timeframe. You could use IPFS directly as you implied with using a local gateway. The biggest struggle any node will have will likely be in finding the data, and retrieving it. I only have 78 peers and I found it fine.

I hope this helps, happy to answer more Qs though.

1 Like

Thanks for your reply!

Its reassuring that the file opens through your gateway. I think that my browser might also have an issue tho, I’ve tried to just simply open the downloaded file in chrome (as opposed to an image viewer), and it still doesn’t load.

I’ve pinned the file on filebase, pinata and locally so not sure if I can do anymore to assist with finding the file on a public gateway but anything I might have overlooked is much appreciated!

1 Like

Hmm it’s a very large image and I always find 1 provider for it. The only thing I can think of trying is to put it on and see if that makes a difference. It’s my favourite service personally because I find it gets my data accessible on the big gateways very quickly. Could be worth a shot.