WEEK 3 QUESTIONS | April 18 - 24, 2021

WEEK 3 QUESTIONS | April 18 - 24, 2021 (times are in EST)

It’s that time of week again! I’ve attempted to highlight interesting or common questions. If you have any ideas on how to reduce these types of questions or solve any of them please comment on the question or below, I’d love to hear your thoughts :smiley:


Pierre D asked “IPFS tiered private setup?” (StackOverflow - 15:35 October 3, 2020)

Is it possible to set up a private IPFS network in a “tiered” or hierarchical way, i.e. such that the peers do not constitute a full bidirectional graph? Some peers could reach others, but others could not “reach back”. There could be several groups of peers, within which all nodes could reach each other (cliques, in other words). Between groups however, the access could be defined as “one-way” only.


This seems like a well thought out question. However I’m not sure how to answer, I highly encourage anyone interested in the question to read the full post, and see if they have any thoughts on it!

barnus11 asked “Git-style repo cloning doesn’t work” (Forum - 8:35 April 22) :white_check_mark:

I’ve followed the tutorial on hosting a git-style repository on ipfs, however when I try to clone the repo with the given command (git clone http://QmX679gmfyaRkKMvPA4WGNWXj9PtpvKWGPgtXaF18etC95.ipfs.localhost:8080/ myrepo)
it doesn’t seem to work. I get a fatal error and git says it is unable to resolve the host QmX679gmfyaRkKMvPA4WGNWXj9PtpvKWGPgtXaF18etC95.ipfs.localhost.
What am I doing wrong? Or is there a configuration step before I can follow this tutorial that I might’ve missed?

lidel answered:

TLDR fix: use loopback IP ( instead of DNS name (localhost):

git clone myrepo

(this way you don’t need to use subdomains on localhost)


lidel’s full answer is stellar! Turns out the user is on Windows, I’m assuming using WSL or similar. Very interesting, I had no idea subdomain gateways were limited on Windows like that!

bellbird asked “is there a mobile GUI available or under development?” (Forum - 3:37 April 24) :white_check_mark:


For anyone else who doesn’t know there’s IPFS Lite available, created by Remmer Wilts.

Ashlynn asked “Browsing a peer’s content” (Forum - 9:09 April 23) :white_check_mark:

I’m somewhat confused about how one gets a CID, in order to browse files on IPFS.

If I’m connected to a peer using the desktop GUI, how am I supposed to get their CID to browse their files?

The “Explore” tab shows some example CID’s, and if I find one in this form, or online, I can browse it, but nothing in this GUI appears to show me the full CID of the peers that I can copy/paste. If I hover over the peer ID, I can find the CID, screenshot, type it in manually… but that seems (obviously) inefficient.

hector answered:

PeerIDs and CIDs are different things, even though they look the same. Although sometimes you can resolve a peer ID to a CID (using /ipns/<peerID>)

You cannot browse the CIDs that a Peer is providing the network.

CIDs are provided either via DNS by IPFS-powered sites (dnslink.io), or by asking people or by visiting places like https://awesome.ipfs.io/.


There’s some interesting discussion there! Seems like there’s interest in sharing MFS with peers :thinking:

abhijeet_ar asked “Can’t fetch files from other nodes” (Forum - 10:29 April 12)

I deployed a private network, where there are multiple nodes connected to a single bootstrap node. For this example, let’s assume there are 3 nodes(A, B, C). A is the bootstrap node. B and C added A to their bootstrap nodes. When B adds a file, C can’t fetch that file until A fetches the file. Is it how it’s implemented, is there a way around or did I make any mistake?


I’ve attempted to answer this question. In this scenario if node A is the bootstrap node, with nodes B and C behind a NAT. If node B adds a file, node C cannot seem to retrieve it while bootstrapped from node A. I’d really appreciate an assist here :blush:

This question is also related (or possibly the same user): distributed system - can't fetch files from other nodes - ipfs - Stack Overflow

nghianguyen119 asked “Running IPFS node on cloud” (Forum - 20:09 April 26) :white_check_mark:

Hi everyone,

I’m new to IPFS, I tried to run an IPFS node on Google Cloud Compute Machine, I initialized with server profile. But the node is not stable as in my local machine. The file get uploaded sometime to the ipfs network but most of the time I can’t get the file from public gateways.

I made an interface to communicate with my node. To add file I use >>ipfs add filename

Anyone know the better way to run node on cloud? I tried with azure but the same problem.


The solution to this question was to forward port 4001! If your node is stuck behind a NAT, it can have trouble serving content to peers.